Savage Wolverine jams when loading from magazine

I know of one so far, let's see if more show up.

Moderator: MudBug

Savage Wolverine jams when loading from magazine

Postby timotheius99 » Sun Mar 10, 2019 7:58 pm

I recently got a 110 Wolverine (.450 Bushmaster) and for the most part I really like it. It shoots very consistent 1.5 inch groups with the standard factory ammo. However, it has one problem. It comes with a detachable Magpul .308 magazine....and the ammo feeds from the magazine very poorly. In fact, almost every round I try to load from the magazine will bind as it travels into the chamber and jams. When it binds, if I wiggle the bolt around it will unbind and then slide into the chamber. Not good enough. It should be chambering my follow up shots smoothly. Also, if I work the bolt very slowly it doesn't bind as much. That also is unacceptable. Bolt actions shouldn't need to be babied. Has anyone else experienced this? Any suggestions on how to solve the problem? It is very frustrating. This gun isn't much use to me if I can't use it for hunting. Is there another magazine that would be better for it?
timotheius99
 
Posts: 4
Joined: Thu Mar 07, 2019 4:13 pm

Re: Savage Wolverine jams when loading from magazine

Postby plant_one » Mon Mar 11, 2019 8:44 am

contact savage - their customer service department is top knotch.

probably just a bad mag. but talk it over with them - i'm sure they'll have an answer for you
User avatar
plant_one
 
Posts: 704
Joined: Sat Mar 19, 2016 8:58 pm
Location: Oakland County, MI

Re: Savage Wolverine jams when loading from magazine

Postby timotheius99 » Mon Mar 11, 2019 9:16 am

I'll give them a call. I don't think its a faulty magazine. I have a second magpul .308 mag and they are exactly the same. Its kind of hard to mess up a pmag. I suspect its more of a design flaw between the action/cartidge/and magazine not working together properly.
timotheius99
 
Posts: 4
Joined: Thu Mar 07, 2019 4:13 pm

Re: Savage Wolverine jams when loading from magazine

Postby plant_one » Fri Mar 15, 2019 12:13 am

both mags have the same feed issue?

if so i have to concur, its probably not a mag thing.

although i cant say i'm familiari with the performance of magpul's ACIS 7.62 mags... i can vouch for the fact that their 7.62 LR/SR mags are the damn beez kneez - at least in my LR308 :)
User avatar
plant_one
 
Posts: 704
Joined: Sat Mar 19, 2016 8:58 pm
Location: Oakland County, MI


Return to Bolt Action Rifles

Who is online

Users browsing this forum: Google [Bot] and 4 guests